Problem getting download to work

May 18, 2009 at 5:41 PM

Hi there,

I would like to use your component which seems fantastic, total freedom to use fonts and on dynamic sites no need to create heading graphics every time someone decides to add in a new page!

BUT, I am having problems getting it to work. I downloaded your test zip and unzipped it to my local machine, pointed IIS (5) to it and ran the test.aspx page successfully. I also added the .* wildcard to the isapi.dll in the .NET 2.0.... folder etc. However, I am not getting the images displaying, in IE just missing images.

So my question is, where are the images supposed to be saved, I assume in the bATRCache folder? I tried setting permissions to all (incl write permission) for everyone but still no images created/displayed.

Any ideas?

Cheers,
Carin

Coordinator
May 18, 2009 at 7:55 PM

Hi Carin,

Thank you for your feedback! I will try to help you setting up the bATR.

There are a few things I noticed in your story that need some clarification. First thing is that bATR used to create images on disk but since a few versions this is changed to an in-memory method. The bATRCach folder is currently only used for catching the .png requests and forward them to an http handler.
Second things is that bATR is actually never tested on an IIS5 instance, so I'm also curious to the solution because the IIS may be the issue(although i do not think so).

Ok, now it's time for solving the issue. What I want you to do is open the test.aspx in your browser. Right click one of the images and copy the image URL. Paste it as the url in your browser and now you should see the real error that occurs when requesting the bATR images. Can you please send that over to me so I can have a look? The errors should also occur in your eventlog...

Best regards,

Bart de Vries

 

May 18, 2009 at 9:17 PM
Hi Bart,
Thanks for getting back to me so quickly! And thanks for offering to try and work this out for me.
The URL of one of the images (bottom one on white background, Symbol font) is http://localhost/bATRCache/theme02,c2w_h2,V09XIStBK21vdXNlb3ZlciE=,0,0,0.png?t=633782812836250000 and that URL just gives me a HTTP 404 - File not found error.
I really appreciate you taking time to help me.
Cheers,
Carin


From: BartDeVries [mailto:notifications@codeplex.com]
Sent: 18 May 2009 20:56
To: carin.l@razorsolutions.com
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,

Thank you for your feedback! I will try to help you setting up the bATR.

There are a few things I noticed in your story that need some clarification. First thing is that bATR used to create images on disk but since a few versions this is changed to an in-memory method. The bATRCach folder is currently only used for catching the .png requests and forward them to an http handler.
Second things is that bATR is actually never tested on an IIS5 instance, so I'm also curious to the solution because the IIS may be the issue(although i do not think so).

Ok, now it's time for solving the issue. What I want you to do is open the test.aspx in your browser. Right click one of the images and copy the image URL. Paste it as the url in your browser and now you should see the real error that occurs when requesting the bATR images. Can you please send that over to me so I can have a look? The errors should also occur in your eventlog...

Best regards,

Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.32/2118 - Release Date: 05/18/09 06:28:00

Coordinator
May 19, 2009 at 6:07 AM
Hi Carin,
 
A 404 means that the wildcard seems not catch the .png request. Let's go through the process of creating the website.
 
So you create a new website within IIS that points to the test folder. After that you can right-click the bATRCache folder and choose for properties. Now you should be able to click a "Create" button so the bATRCache becomes a application.
 
Now you can add the .png handler by hitting "Configuration" and go to the Mappings tab. Here you add an .png extension pointing to the isapi.dll. Also make sure the "Verify that file exists" is NOT checked... the files are virtual so this would through 404's.
 
What happens now? If you want I can email you some images explaining the IIS configuration.
 
Best regards,
 
Bart de Vries
 
 


 
On Mon, May 18, 2009 at 11:17 PM, carinlindberg <notifications@codeplex.com> wrote:

From: carinlindberg

Hi Bart,
Thanks for getting back to me so quickly! And thanks for offering to try and work this out for me.
The URL of one of the images (bottom one on white background, Symbol font) is http://localhost/bATRCache/theme02,c2w_h2,V09XIStBK21vdXNlb3ZlciE=,0,0,0.png?t=633782812836250000 and that URL just gives me a HTTP 404 - File not found error.
I really appreciate you taking time to help me.
Cheers,
Carin


From: BartDeVries [mailto:[email removed]]
Sent: 18 May 2009 20:56
To: [email removed]
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,

Thank you for your feedback! I will try to help you setting up the bATR.

There are a few things I noticed in your story that need some clarification. First thing is that bATR used to create images on disk but since a few versions this is changed to an in-memory method. The bATRCach folder is currently only used for catching the .png requests and forward them to an http handler.
Second things is that bATR is actually never tested on an IIS5 instance, so I'm also curious to the solution because the IIS may be the issue(although i do not think so).

Ok, now it's time for solving the issue. What I want you to do is open the test.aspx in your browser. Right click one of the images and copy the image URL. Paste it as the url in your browser and now you should see the real error that occurs when requesting the bATR images. Can you please send that over to me so I can have a look? The errors should also occur in your eventlog...

Best regards,

Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.32/2118 - Release Date: 05/18/09 06:28:00

Read the full discussion online.

To add a post to this discussion, reply to this email (bATR@discussions.codeplex.com)

To start a new discussion for this project, email bATR@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


May 19, 2009 at 9:20 AM
OK, so that's something I hadn't done before. I had put the wildcard on the web site virtual folder and hadn't created an app of the bATRCache folder. So, now made bATR into an app and added the .png wildcard to that folder only (took off teh .* wildcard on the wbe site folder).
Now when I try one of the URLs of the images I get this error:

Server Error in '/bATRCache' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'bATR' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 4:  	<system.web>
Line 5:  		<httpHandlers>
Line 6:  			<add verb="*" path="*.png" validate="false" type="bATR.Handlers.ImageHandlerBase, bATR" />
Line 7:  		</httpHandlers>
Line 8:  	</system.web>

Source File: D:\3rdParty\bATR\bATRwww_1.6.6\bATRwww\batrcache\web.config Line: 6

Assembly Load Trace: The following information can be helpful to determine why the assembly 'bATR' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
So one step further I think!
Cheers,
Carin


Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082


From: BartDeVries [mailto:notifications@codeplex.com]
Sent: 19 May 2009 07:08
To: carin.l@razorsolutions.com
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,
A 404 means that the wildcard seems not catch the .png request. Let's go through the process of creating the website.
So you create a new website within IIS that points to the test folder. After that you can right-click the bATRCache folder and choose for properties. Now you should be able to click a "Create" button so the bATRCache becomes a application.
Now you can add the .png handler by hitting "Configuration" and go to the Mappings tab. Here you add an .png extension pointing to the isapi.dll. Also make sure the "Verify that file exists" is NOT checked... the files are virtual so this would through 404's.
What happens now? If you want I can email you some images explaining the IIS configuration.
Best regards,
Bart de Vries


On Mon, May 18, 2009 at 11:17 PM, carinlindberg <notifications@codeplex.com> wrote:

From: carinlindberg

Hi Bart,
Thanks for getting back to me so quickly! And thanks for offering to try and work this out for me.
The URL of one of the images (bottom one on white background, Symbol font) is http://localhost/bATRCache/theme02,c2w_h2,V09XIStBK21vdXNlb3ZlciE=,0,0,0.png?t=633782812836250000 and that URL just gives me a HTTP 404 - File not found error.
I really appreciate you taking time to help me.
Cheers,
Carin


From: BartDeVries [mailto:[email removed]]
Sent: 18 May 2009 20:56
To: [email removed]
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,

Thank you for your feedback! I will try to help you setting up the bATR.

There are a few things I noticed in your story that need some clarification. First thing is that bATR used to create images on disk but since a few versions this is changed to an in-memory method. The bATRCach folder is currently only used for catching the .png requests and forward them to an http handler.
Second things is that bATR is actually never tested on an IIS5 instance, so I'm also curious to the solution because the IIS may be the issue(although i do not think so).

Ok, now it's time for solving the issue. What I want you to do is open the test.aspx in your browser. Right click one of the images and copy the image URL. Paste it as the url in your browser and now you should see the real error that occurs when requesting the bATR images. Can you please send that over to me so I can have a look? The errors should also occur in your eventlog...

Best regards,

Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.32/2118 - Release Date: 05/18/09 06:28:00

Read the full discussion online.

To add a post to this discussion, reply to this email (bATR@discussions.codeplex.com)

To start a new discussion for this project, email bATR@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.33/2120 - Release Date: 05/18/09 06:28:00

Coordinator
May 19, 2009 at 9:43 AM

Hi Carin,

Because we just created an application the bATRCache folder is not able to locate the bATR binaries that are one level up. Now it is going to be a bit tricky... In IIS 6 there is a fix by opening the bATRCache folder properties and click "remove" for the application. The .png handler is still maintained and active now. I think that fix may apply on IIS5 also...

What are the resuls? A different solution would be by creating a bin folder within the bATR cache folder with the bATR dll.

Regards,

 

Bart de Vries

 

 

May 19, 2009 at 12:26 PM
Oh cool, that works!! :)
Thank you so much for that, now I just need to work it into my own application.
Thank you so much for your support, rare to find people who are so helpful and quick to respond!

Cheers,
Carin


From: BartDeVries [mailto:notifications@codeplex.com]
Sent: 19 May 2009 10:43
To: carin.l@razorsolutions.com
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,

Because we just created an application the bATRCache folder is not able to locate the bATR binaries that are one level up. Now it is going to be a bit tricky... In IIS 6 there is a fix by opening the bATRCache folder properties and click "remove" for the application. The .png handler is still maintained and active now. I think that fix may apply on IIS5 also...

What are the resuls? A different solution would be by creating a bin folder within the bATR cache folder with the bATR dll.

Regards,

Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.33/2120 - Release Date: 05/19/09 06:21:00

May 19, 2009 at 2:08 PM
Hello, me again!

I have now tried to incorporate this into my .NET 3.5 application. I have copied in the bATR and bATRCache folders (of which I have set up as an app, added the .png and then removed the app again like before) into my web root, added the bATR.config into the root as well and also put the dll and xml file into the bin folder, added the relevant sections to web.config:

<appSettings>
<add key="batrConfigFile" value="~/bATR.config" />
</appSettings>

and..

<authentication mode="Windows">
<forms name="bATRCookie" timeout="300" path="/"></forms>
</authentication>

and..

<pages maintainScrollPositionOnPostBack="true">
<controls>
<add tagPrefix="bATR" namespace="bATR.Controls" assembly="bATR" />
</controls>
</pages>

but now get error when trying to build in VS, saying The type or namespace name 'Windows' does not exist in the class or namespace 'System' (are you missing an assembly reference?)
As far as I know Windows namespace is only used when working with windows forms, my app is a web app...
Any ideas of how to solve this?
Cheers,
Carin


From: BartDeVries [mailto:notifications@codeplex.com]
Sent: 19 May 2009 10:43
To: carin.l@razorsolutions.com
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,

Because we just created an application the bATRCache folder is not able to locate the bATR binaries that are one level up. Now it is going to be a bit tricky... In IIS 6 there is a fix by opening the bATRCache folder properties and click "remove" for the application. The .png handler is still maintained and active now. I think that fix may apply on IIS5 also...

What are the resuls? A different solution would be by creating a bin folder within the bATR cache folder with the bATR dll.

Regards,

Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.33/2120 - Release Date: 05/19/09 06:21:00

May 19, 2009 at 2:51 PM
And again...
I excluded the bATR folders from the VS project, which then builds fine and now the control works, so I get the correct image.
I assume I can replace all that with just the DLL, so I will try that now. Want it part of project as publish is a lot easier/straightforward.
Cheers,
Carin


From: BartDeVries [mailto:notifications@codeplex.com]
Sent: 19 May 2009 10:43
To: carin.l@razorsolutions.com
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries

Hi Carin,

Because we just created an application the bATRCache folder is not able to locate the bATR binaries that are one level up. Now it is going to be a bit tricky... In IIS 6 there is a fix by opening the bATRCache folder properties and click "remove" for the application. The .png handler is still maintained and active now. I think that fix may apply on IIS5 also...

What are the resuls? A different solution would be by creating a bin folder within the bATR cache folder with the bATR dll.

Regards,

Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.33/2120 - Release Date: 05/19/09 06:21:00

Coordinator
May 19, 2009 at 3:41 PM

Hi Carin,
 
You have to add the reference because bATR is using WPF for creating the texts. Within the bATR .csproj you will see that the PresentationCore and PresentationFramework are included.
 
What happens now?
 
Regards,
 
Bart de Vries
May 19, 2009 at 5:50 PM
Hi again,
OK, I understand. I'm not sure why the solution won't build with that ref to the System.Windows namespace. I don't have the csproj, don't think the download (bATRwww_1.6.6.zip) contained that...
I am running a .NET 3.5 web app and now I have only got the bATR.config in the root of my app, the bATRCache folder (with just the web.config file) and the bATR folder (only containing the Images and Font folders plus the web.config) plus the 3 things added to my app web.config. It all runs fine just referencing the DLL in my bin folder which also has the bATR.xml file.
So all in all it works beautifully now! I am running it on a multi-site structure using the sitename as a theme and the bATR control for adding page headings in h1 tags - brilliant! And no more tedious creating of millions of heading images each time we add a new site!

Thanks so much for your great component!

Cheers,
Carin


From: BartDeVries [mailto:notifications@codeplex.com]
Sent: 19 May 2009 16:41
To: carin.l@razorsolutions.com
Subject: Re: Problem getting download to work [bATR:56677]

From: BartDeVries


Hi Carin,
You have to add the reference because bATR is using WPF for creating the texts. Within the bATR .csproj you will see that the PresentationCore and PresentationFramework are included.
What happens now?
Regards,
Bart de Vries

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.329 / Virus Database: 270.12.33/2120 - Release Date: 05/19/09 06:21:00

Coordinator
May 19, 2009 at 7:02 PM
Sounds good Carin! I'd love to see the results!
 
Regards,
 
Bart de Vries